Triplanar mapping not working

Forums: Triplanar mapping not working
Maxon Cinema 4D (Export script developed by abstrax, Integrated Plugin developed by aoktar)

Moderator: aoktar

Triplanar mapping not working

Postby zabadoy » Wed Oct 09, 2019 4:33 pm

zabadoy Wed Oct 09, 2019 4:33 pm
Hello all,

I've received an .obj file from a client, and I can't get to make Triplanar mapping working in Octane.
As you can see in the scene, I have created a material with a checker texture, a triplanar node and a texture projection node set to triplanar as usual. It works on the basic primitives and on the figure but nothing happens on the object... I've tried scaling it's UV's, remaking them by reprojecting them, nothing works. Otherwise UV, Cubic or any mapping type works well (see second pic), but Triplanar stays blank.

Has anyone encountered this situation or have any idea about what the problem could be ?
Note that the object is weirdly meshed with triangles like it often happens with .obj exports from client files, could that be the problem ?

Thank you in advance for your help !
Attachments
Triplanar2.png
UV Mapping working
Triplanar.png
Triplanar not working
zabadoy
Licensed Customer
Licensed Customer
 
Posts: 11
Joined: Sun Oct 14, 2018 10:45 am

Re: Triplanar mapping not working

Postby aoktar » Wed Oct 09, 2019 4:41 pm

aoktar Wed Oct 09, 2019 4:41 pm
You have to connect triplanar projection to textures. It should be mentioned in help manual.
User avatar
aoktar
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 12718
Joined: Tue Mar 23, 2010 8:28 pm
Location: Türkiye

Re: Triplanar mapping not working

Postby zabadoy » Wed Oct 09, 2019 5:01 pm

zabadoy Wed Oct 09, 2019 5:01 pm
Hello Aoktar,

Thanks for your reply, I didn't know that.
It works with a texture indeed. Still really weirdly scaled, compared to other objects but is has probably to do with the mesh UV's then, will check that.
zabadoy
Licensed Customer
Licensed Customer
 
Posts: 11
Joined: Sun Oct 14, 2018 10:45 am

Re: Triplanar mapping not working

Postby aoktar » Wed Oct 09, 2019 8:19 pm

aoktar Wed Oct 09, 2019 8:19 pm
zabadoy wrote:Hello Aoktar,

Thanks for your reply, I didn't know that.
It works with a texture indeed. Still really weirdly scaled, compared to other objects but is has probably to do with the mesh UV's then, will check that.

mesh uv's are not important when you use triplanar.
Octane For Cinema 4D developer / 3d generalist

3930k / 16gb / 780ti + 1070/1080 / psu 1600w / numerous hw
User avatar
aoktar
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 12718
Joined: Tue Mar 23, 2010 8:28 pm
Location: Türkiye

Return to Maxon Cinema 4D


Who is online

Users browsing this forum: Baidu [Spider] and 8 guests

Sun Dec 15, 2019 6:47 pm [ UTC ]