Mograph Color Shader falloff weirdness

A public forum for discussing and asking questions about the demo version of Octane Render.
Forum rules
For new users: this forum is moderated. Your first post will appear only after it has been reviewed by a moderator, so it will not show up immediately.
This is necessary to avoid this forum being flooded by spam.

Mograph Color Shader falloff weirdness

Postby Doctor_Pizza » Thu Mar 16, 2017 6:52 pm

In my project, a Shader effector with falloff is changing the color of clones from black to white. This is wired up to the Octane emission tab, so you can think of it turning on a series of lightbulbs in sequence.

If I use a preset Falloff Function like Linear or Inverse Square, it works as expected: Lights change from pure black to pure white. (see attached project)

But if I use a custom drawn Spline Falloff Function, the clones never start completely black. They always start as dark grey, which is unexpected behavior.

Any ideas what's going on and how to fix it so they start off completely black?
Attachments
Octane-MographShaderTest_001.c4d.zip
(70.94 KiB) Downloaded 144 times
Doctor_Pizza
 
Posts: 15
Joined: Wed Jul 13, 2016 8:46 pm
Location: Los Angeles, California USA

Re: Mograph Color Shader falloff weirdness

Postby Doctor_Pizza » Fri Mar 24, 2017 1:41 am

Can other users replicate this issue? :?:
Octane 3 / C4D R17 / Win 7 64 SP 1 / Dual GTX Titan X (Driver 368.69) / Dual Xeon E5-2680 v3 @ 2.50GHz / 64GB RAM
Doctor_Pizza
 
Posts: 15
Joined: Wed Jul 13, 2016 8:46 pm
Location: Los Angeles, California USA

Re: Mograph Color Shader falloff weirdness

Postby bepeg4d » Fri Mar 24, 2017 3:08 pm

Hi Doctor,
I have slightly moved to the left the selected point of the custom curve and now the cubes are black when turned off, please try with the attached file:
Screen Shot 2017-03-24 at 16.05.10.jpg

Octane-MographShaderTest_001b.c4d.zip
(66.21 KiB) Downloaded 185 times

ciao beppe
Octane Support
MacPro 2x2,26 Ghz / 16GB Ram / GTX 1070 + GTX 970 / OsX 10.12.6
MSI Z77A-GD65 / 3570K 3.4 Ghz / 16 GB ram / Quadro K620 + GTX 1070 + GTX 780
OctaneRender™ Italia
User avatar
bepeg4d
Octane Guru
Octane Guru
 
Posts: 4877
Joined: Wed Jun 02, 2010 6:02 am
Location: Italy

Re: Mograph Color Shader falloff weirdness

Postby Doctor_Pizza » Fri Mar 24, 2017 10:10 pm

Unbelievable! Thank you very much!

I can't believe the answer was such a tiny shift of spline points to the left ! :o

Screen-Shot-2017-03-24-at-3.06.15-PM.gif
Screen-Shot-2017-03-24-at-3.06.15-PM.gif (40.65 KiB) Viewed 1872 times
Octane 3 / C4D R17 / Win 7 64 SP 1 / Dual GTX Titan X (Driver 368.69) / Dual Xeon E5-2680 v3 @ 2.50GHz / 64GB RAM
Doctor_Pizza
 
Posts: 15
Joined: Wed Jul 13, 2016 8:46 pm
Location: Los Angeles, California USA

Return to Demo Version Questions & Discussion


Who is online

Users browsing this forum: No registered users and 4 guests

Tue Sep 19, 2017 5:20 pm [ UTC ]