OctaneRender™ Standalone 4.04

Forums: OctaneRender™ Standalone 4.04
VIP Information, news and announcements regarding new Octane Render commercial products and releases.

Re: OctaneRender™ Standalone 4.04 [current 4.xx]

Postby Jolbertoquini » Wed May 08, 2019 12:43 pm

Jolbertoquini Wed May 08, 2019 12:43 pm
Jolbertoquini wrote:Hi Guys,

We are having some issues with our internal tools with the 4.0.4 : https://render.otoy.com/forum/viewtopic.php?f=73&t=71439&e=0

basically this:

I'm trying to query pin names/labels for the NT_GEO_GROUP and have found that this used to work in Octane 3.06.4 but now no longer works in Octane 4.04. Has this API changed? I've checked in the documentation and there are no differences that I can see. For example with the following script:

Code: Select all
local geogroup = getNodeTypeByName("MyGeoGroup", octane.NT_GEO_GROUP)
if (geogroup ~= nil) then
  print(geogroup:getPinCount())
  for jj=1,geogroup:getPinCount() do
    local lp = geogroup:getPinInfoIx(jj)
    print("description " .. lp.description .. " type " .. lp.type .. " label " .. lp.label .. " name " .. lp.name)
  end
end


Octane 3.06.3 Output:
1
description Geometry Input type 12 label Input 1 name Input 1

Octane 4.04 Output:
1
description Geometry Input type 12 label name unknown

I can see in the Node inspector UI that for both versions the pin details have the name as "Input 1", so am confused why I cannot query this string in the newer version of Octane?



So after a extra test is coming after the version 4.0.3 which seams this update "Fixed octane.node.getPinInfoIx().name which was returning the label instead of the pin name." is giving errors to us based on the script on the top the Octane version 4.0.2.1 is working fine.


Best,
JO



Hi Haze,

Please we are waiting for the fix of the lua script , spend more then a week i think the Guys has a fix could we have a quick release with that fixe please?

Best,
JO
Octane Render for Maya.
https://vimeo.com/jocg/videos
https://www.linkedin.com/in/jocgtd
http://www.hmxmedia.com/
--------------------
Join MAYA OCTANE USERS Skype discussion here :
https://join.skype.com/LXEQaqqfN15w
User avatar
Jolbertoquini
Licensed Customer
Licensed Customer
 
Posts: 957
Joined: Sun Aug 31, 2014 7:08 am
Location: London

Re: OctaneRender™ Standalone 4.04 [current 4.xx]

Postby Jolbertoquini » Wed Jun 05, 2019 9:19 am

Jolbertoquini Wed Jun 05, 2019 9:19 am
Hello Haze,

Any news I though they find the fix weeks a go for that and should be a release with the Lua script fix for the pin.

Please we need that to roll out here we have more then 100 licenses to roll to OC 4 and change to subscription. for the next 2018.2 but the fact they changed the Lua pin on this version we can't do that we need use Octane for in some machines.

We need update.

Appreciate to have more news, reply a sign of life please!

Best,
JO
Octane Render for Maya.
https://vimeo.com/jocg/videos
https://www.linkedin.com/in/jocgtd
http://www.hmxmedia.com/
--------------------
Join MAYA OCTANE USERS Skype discussion here :
https://join.skype.com/LXEQaqqfN15w
User avatar
Jolbertoquini
Licensed Customer
Licensed Customer
 
Posts: 957
Joined: Sun Aug 31, 2014 7:08 am
Location: London

Re: OctaneRender™ Standalone 4.04 [current 4.xx]

Postby zoppo » Fri Jun 07, 2019 3:36 pm

zoppo Fri Jun 07, 2019 3:36 pm
Hi,

I have big problems with the shadow pass. It happens in 4.04-R2 for C4D and in 4.04 Standalone.

I have prepared a minimized scene:

http://www.3dfisch.de/forum/shadow_pass.zip

The pass looks like this - noise in high contrast areas (light sampling doesn't change a thing), and faceting on the object, phong is ignored:
Image

When activating the object "sky" in my scene - a big hemisphere with a emissive material with a HDRI - it looks like this:
Image

Best regards,
Marc
C4D 20 MSA | Win10
User avatar
zoppo
Licensed Customer
Licensed Customer
 
Posts: 244
Joined: Wed Dec 09, 2015 10:37 am
Location: München

Re: OctaneRender™ Standalone 4.04 [current 4.xx]

Postby zoppo » Thu Jun 13, 2019 8:29 am

zoppo Thu Jun 13, 2019 8:29 am
Bump
C4D 20 MSA | Win10
User avatar
zoppo
Licensed Customer
Licensed Customer
 
Posts: 244
Joined: Wed Dec 09, 2015 10:37 am
Location: München

Re: OctaneRender™ Standalone 4.04 [current 4.xx]

Postby haze » Mon Jun 17, 2019 2:30 am

haze Mon Jun 17, 2019 2:30 am
zoppo wrote:Hi,

I have big problems with the shadow pass. It happens in 4.04-R2 for C4D and in 4.04 Standalone.

I have prepared a minimized scene:

http://www.3dfisch.de/forum/shadow_pass.zip

The pass looks like this - noise in high contrast areas (light sampling doesn't change a thing), and faceting on the object, phong is ignored:
Image

When activating the object "sky" in my scene - a big hemisphere with a emissive material with a HDRI - it looks like this:
Image

Best regards,
Marc



We will be releasing 4.05 (a small update) shortly but we haven't had a chance to investigate this yet. We will take a look and get back to you.
User avatar
haze
OctaneRender Team
OctaneRender Team
 
Posts: 800
Joined: Sun Feb 08, 2015 8:57 pm
Previous

Return to Commercial Product News & Releases (Download here)


Who is online

Users browsing this forum: No registered users and 2 guests

Sun Oct 20, 2019 4:01 am [ UTC ]