ORBX Files animated textures incorrect.

Forums: ORBX Files animated textures incorrect.
Discussion forum for RNDR
Forum rules
For support questions please visit help.otoy.com or contact [email protected]

ORBX Files animated textures incorrect.

Postby ianmcdan » Mon Nov 16, 2020 7:54 pm

ianmcdan Mon Nov 16, 2020 7:54 pm
I'm having an issue in C4D exporting animated textures into ORBX files for use on RNDR. Apologies if this is the wrong place to post this, but I'm pulling my hair out trying to get this right.

I have frame ranges set in the image texture node. PNG Sequences. Let's say I use frame 0-100 @ 30fps... in a 30fps document, rendering out 30fps. Then I set it to simple, exact frame and render out 100 frames... I'm lucky if I get 30-40 frames to render and it repeats frames.. sometimes 2-3fps.

Any ideas?

C4D R23
Octane 2020.1.5
C4D Plugin 2020.1.5-R4 (MacOS CUDA)
High Sierra 10.13.6
ianmcdan
Licensed Customer
Licensed Customer
 
Posts: 9
Joined: Mon Apr 27, 2015 12:45 am

Re: ORBX Files animated textures incorrect.

Postby bepeg4d » Tue Nov 17, 2020 7:49 am

bepeg4d Tue Nov 17, 2020 7:49 am
Hi,
please save the c4d project with assets, compress the resulting folder, and share a link to dropbox or google drive, or any other similar service, via Private Message to me, thanks.

ciao Beppe
User avatar
bepeg4d
Octane Guru
Octane Guru
 
Posts: 8620
Joined: Wed Jun 02, 2010 6:02 am
Location: Italy

Re: ORBX Files animated textures incorrect.

Postby ianmcdan » Mon Jan 25, 2021 8:02 pm

ianmcdan Mon Jan 25, 2021 8:02 pm
Sorry for the late response to this. I would have to change out hundreds of textures to provide that file... and it's full of things that are under heavy NDA.

BUT...

I have determined that it's an issue with the Mac version of Octane for Cinema4D and it's ORBX exporting. Works fine on windows, and I've replicated the problem on multiple Mac systems, using the latest versions. It's not just textures that aren't updating... it's full frames of animation... sometimes 2-3 frames of the same frame, then it jumps to where is should be. It seems to have gotten worse with the most recent updates.

For now.. I'll just use Windows to do the ORBX exports. But there is definitely a bug somewhere. It's been happening on files that have exported fine before.. and brand new files too.
ianmcdan
Licensed Customer
Licensed Customer
 
Posts: 9
Joined: Mon Apr 27, 2015 12:45 am

Re: ORBX Files animated textures incorrect.

Postby bepeg4d » Tue Jan 26, 2021 7:37 am

bepeg4d Tue Jan 26, 2021 7:37 am
Hi,
thr devs are investigating the issue, in the meantime, please try to export the .orbx scene via Terminal/command line, here is the syntax for R23:

Code: Select all
“/Applications/Maxon\ Cinema\ 4D\ R23/Cinema\ 4D.app/Contents/MacOS/Cinema\ 4D”  “path to .c4d scene”  -nogui -exportORBX “path to .orbx saving”


Basically you need to right click on c4d app, choose Show package content, navigate into Contenta/MacOs and drag and drop the Cinema 4D exe file in the Terminal window:
Image

Drag and drop from the finder the desired .c4d file, then write `-nogui -exportORBX` and then the path where to save the desired .orbx file.

In my tests it has always worked 100% with both Catalina and Big Sur, please let me know if it works also for you.

If you have AI Denoiser active in the scene, you will see an error at the end of the export, but the exported .orbx scene will render correctly in RNDR:
744F1219-E97C-425D-BB58-BCD2D335CC5E.png


ciao Beppe
User avatar
bepeg4d
Octane Guru
Octane Guru
 
Posts: 8620
Joined: Wed Jun 02, 2010 6:02 am
Location: Italy

Re: ORBX Files animated textures incorrect.

Postby ultramajic.com » Tue May 25, 2021 8:53 pm

ultramajic.com Tue May 25, 2021 8:53 pm
Can anyone let me know the latest update on this issue? I'm now using Big Sur with the latest METAL version. I can not get this terminal thing to work... followed the steps correctly from what I can tell.

Is there any way to know if the ORBX file is working? when I export to an Animated Package, it seems to be exporting frames without the viewport updating, which makes me think that its not working properly.
ultramajic.com
Licensed Customer
Licensed Customer
 
Posts: 6
Joined: Tue Oct 18, 2016 3:45 am

Re: ORBX Files animated textures incorrect.

Postby ultramajic.com » Tue May 25, 2021 9:02 pm

ultramajic.com Tue May 25, 2021 9:02 pm
-deleted-

Just realized you must press space bar after every command.. I'm new to Terminal
ultramajic.com
Licensed Customer
Licensed Customer
 
Posts: 6
Joined: Tue Oct 18, 2016 3:45 am

Re: ORBX Files animated textures incorrect.

Postby snahbah » Thu Oct 14, 2021 3:00 pm

snahbah Thu Oct 14, 2021 3:00 pm
This solution doesn't work if you have plugins like XPaticles, Quixel Bridge, etc.

Any ideas how to get this working. My files names all have an underscore heifer their numbers.

On a deadline here and leaning heavily on RNDR doing it's job. I have no problems rendering locally apart from the time it will take.

Hope there's an answer
snahbah
Licensed Customer
Licensed Customer
 
Posts: 14
Joined: Sun Dec 08, 2019 11:52 pm

Return to RNDR


Who is online

Users browsing this forum: No registered users and 2 guests

Sat Oct 16, 2021 1:01 am [ UTC ]