Octane crashes constantly

Forums: Octane crashes constantly
A public forum for discussing and asking questions about the Octane for Unity Alpha

Moderator: ChrisHekman

Octane crashes constantly

Postby jdinh » Mon Jun 17, 2019 3:20 pm

jdinh Mon Jun 17, 2019 3:20 pm
I'm having tons of issues using Octane with Unity. Anyone else?

I am using Unity 2018.4 and OctaneRender 1.2.0.1370.

I'm trying to use it in realtime with the render view and I can't go 2 minutes without the renderer crashing and throwing this error. Help!

Code: Select all
CUDA error 700 on device 0: an illegal memory access was encountered
  -> could not get memory info
CUDA error 700 on device 0: an illegal memory access was encountered
  -> could not get memory info
CUDA error 700 on device 1: an illegal memory access was encountered
  -> failed to unregister pinned memory
CUDA error 700 on device 1: an illegal memory access was encountered
  -> could not get memory info
CUDA error 700 on device 1: an illegal memory access was encountered
  -> failed to unregister pinned memory
CUDA error 700 on device 1: an illegal memory access was encountered
  -> could not get memory info
CUDA error 700 on device 0: an illegal memory access was encountered
  -> failed to load symbol data to the device(deep_data)
device 0: failed to upload the deep params
CUDA error 700 on device 1: an illegal memory access was encountered
  -> failed to load symbol data to the device(deep_data)
device 1: failed to upload the deep params


EDIT: OK so update, I guess the cause of the crashing is trying to operate in real time? I have set my render target as the "Editor" so when I am making live changes and it tries to render as quickly as I am making live changes, it crashes. Is this not a technically feasible way to operate with the renderer?
jdinh
Licensed Customer
Licensed Customer
 
Posts: 4
Joined: Sun Jun 09, 2019 3:17 am

Re: Octane crashes constantly

Postby ChrisHekman » Tue Jun 18, 2019 9:14 am

ChrisHekman Tue Jun 18, 2019 9:14 am
Are you using the latest nvidia driver?
Which GPU are you using?
ChrisHekman
OctaneRender Team
OctaneRender Team
 
Posts: 398
Joined: Wed Jan 18, 2017 3:09 pm

Re: Octane crashes constantly

Postby jdinh » Tue Jun 18, 2019 11:24 am

jdinh Tue Jun 18, 2019 11:24 am
ChrisHekman wrote:Are you using the latest nvidia driver?
Which GPU are you using?


I'm using 2 2080's with latest driver version 430.86. I've mitigated it a great deal by disconnecting the 2080 displays and moving all my windows to a 3rd GPU that isn't being used for rendering. So now there isn't any other process that disrupts the renderer. Now it happens a lot less but will still happen a couple times within a 1 hour session. Usually when I am changing settings or switching the render targets. :(
jdinh
Licensed Customer
Licensed Customer
 
Posts: 4
Joined: Sun Jun 09, 2019 3:17 am

Re: Octane crashes constantly

Postby ChrisHekman » Thu Jun 20, 2019 3:36 pm

ChrisHekman Thu Jun 20, 2019 3:36 pm
jdinh wrote:
ChrisHekman wrote:Are you using the latest nvidia driver?
Which GPU are you using?


I'm using 2 2080's with latest driver version 430.86. I've mitigated it a great deal by disconnecting the 2080 displays and moving all my windows to a 3rd GPU that isn't being used for rendering. So now there isn't any other process that disrupts the renderer. Now it happens a lot less but will still happen a couple times within a 1 hour session. Usually when I am changing settings or switching the render targets. :(


Does the issue will happen with the latest build? We upgraded to Octane 2018.1.3. It might have fixed your issue.
If it hasnt, you should post your issue on viewforum.php?f=33
ChrisHekman
OctaneRender Team
OctaneRender Team
 
Posts: 398
Joined: Wed Jan 18, 2017 3:09 pm

Re: Octane crashes constantly

Postby linecrest » Wed Aug 07, 2019 7:02 pm

linecrest Wed Aug 07, 2019 7:02 pm
Having same problem. I am in C4D R20 and Octane 2018.1.3 crashes constantly, I'm using a:

Mac Tower
2 x 3.46 GHz 6-Core Intel Xeon
(chipped) NVIDIA GeForce GTX 980 TI 6144 MB.
120 GB RAM

I get a different error code. Here's mine:

Code: Select all
Process:         CINEMA 4D [2844]
Path:            /Applications/MAXON/*/CINEMA 4D.app/Contents/MacOS/CINEMA 4D
Architecture:    x86_64
Parent:          launchd [1]
UID:             501
Task size:       1341.96 MB
CPU Time:        0.035s (85.2M cycles, 24.0M instructions, 3.54c/i)
Note:            Unresponsive for 318 seconds before sampling
Note:            1 idle work queue thread omitted

  Thread 0x76b33            DispatchQueue 1           11 samples (1-11)         priority 47 (base 47)
  <process frontmost, thread QoS user interactive (requested user interactive, requested override user interactive), process unclamped, process received importance donation from WindowServer [201], IO tier 0>
  11  start + 1 (libdyld.dylib + 4117) [0x7fff56a18015] 1-11
    11  ??? (CINEMA 4D + 25724) [0x1094da47c] 1-11
      11  ??? (CINEMA 4D + 26690) [0x1094da842] 1-11
        11  ??? (CINEMA 4D + 21496) [0x1094d93f8] 1-11
          11  NSApplicationMain + 804 (AppKit + 23154) [0x7fff2bf9ea72] 1-11
            11  -[NSApplication run] + 812 (AppKit + 223413) [0x7fff2bfcf8b5] 1-11
              11  -[NSApplication(NSEvent) sendEvent:] + 1659 (AppKit + 8216339) [0x7fff2c76ef13] 1-11
                11  -[NSWindow(NSEventRouting) sendEvent:] + 497 (AppKit + 9915504) [0x7fff2c90dc70] 1-11
                  11  -[NSWindow(NSEventRouting) _reallySendEvent:isDelayedEvent:] + 4787 (AppKit + 9921344) [0x7fff2c90f340] 1-11
                    11  -[NSTrackingArea mouseMoved:] + 150 (AppKit + 2420909) [0x7fff2c1e80ad] 1-11
                      11  ??? (<8452C19A-BB8D-3FA1-A8A6-043C82B41153> + 15226281) [0x10d2fe5a9] 1-11
                        11  ??? (<8452C19A-BB8D-3FA1-A8A6-043C82B41153> + 732742) [0x10c52be46] 1-11
                          11  ??? (<8452C19A-BB8D-3FA1-A8A6-043C82B41153> + 3549751) [0x10c7dba37] 1-11
                            11  ??? (<8452C19A-BB8D-3FA1-A8A6-043C82B41153> + 11759786) [0x10cfb00aa] 1-11
                              11  ??? (<8452C19A-BB8D-3FA1-A8A6-043C82B41153> + 16606653) [0x10d44f5bd] 1-11
                                11  ??? (<8452C19A-BB8D-3FA1-A8A6-043C82B41153> + 4427762) [0x10c8b1ff2] 1-11
                                  11  ??? (<8452C19A-BB8D-3FA1-A8A6-043C82B41153> + 4428951) [0x10c8b2497] 1-11
                                    11  ??? (CINEMA 4D + 1442566) [0x109634306] 1-11
                                      11  ??? (CINEMA 4D + 2359554) [0x109714102] 1-11
                                        11  __psynch_cvwait + 10 (libsystem_kernel.dylib + 117270) [0x7fff56b68a16] 1-11
                                         *11  psynch_cvcontinue + 0 (pthread + 38948) [0xffffff7f82cb5824] 1-11



It's kind of relentless. Not sure how to proceed.
linecrest
 
Posts: 1
Joined: Mon May 14, 2018 3:44 pm

Re: Octane crashes constantly

Postby ChrisHekman » Mon Aug 12, 2019 9:44 am

ChrisHekman Mon Aug 12, 2019 9:44 am
This is a Cinema4D crash, you should post this in the Cinema 4D forum.
ChrisHekman
OctaneRender Team
OctaneRender Team
 
Posts: 398
Joined: Wed Jan 18, 2017 3:09 pm

Return to Octane for Unity


Who is online

Users browsing this forum: No registered users and 1 guest

Sat Oct 19, 2019 3:10 am [ UTC ]