Frequent null exceptions when trying to render with Recorder

Forums: Frequent null exceptions when trying to render with Recorder
A public forum for discussing and asking questions about the Octane for Unity Alpha

Moderator: ChrisHekman

Frequent null exceptions when trying to render with Recorder

Postby Dreamwriter » Sat Dec 22, 2018 8:01 am

Dreamwriter Sat Dec 22, 2018 8:01 am
When trying to start a Recording, we are getting this error. It's happening so often that it gets frustrating. We then reload the scene, change nothing, and it works. But it'll often get the error 9 times out of 10 tries, it's very frustrating. Once the capture starts it works great. We are recording based on Frames, starting from example frame 50. We get the error no matter how many frames we render, frame 50 to 50 or frame 50 to 600.

Image

Unity 2018.2.17, Octane 1.2.0.1362, Windows 10.
Dreamwriter
 
Posts: 5
Joined: Wed Oct 31, 2018 5:41 pm

Re: Frequent null exceptions when trying to render with Recorder

Postby ChrisHekman » Mon Jan 07, 2019 1:03 pm

ChrisHekman Mon Jan 07, 2019 1:03 pm
I cannot recreate this issue on my end.

Is this for every scene or for a specific scene you are using?
If it only happens for a specific scene, could you PM me your project?
ChrisHekman
OctaneRender Team
OctaneRender Team
 
Posts: 218
Joined: Wed Jan 18, 2017 3:09 pm

Re: Frequent null exceptions when trying to render with Recorder

Postby Dreamwriter » Mon Jan 07, 2019 10:29 pm

Dreamwriter Mon Jan 07, 2019 10:29 pm
We had it happen in two scenes (which unfortunately I don't think we can send, as our Unity app and those scenes are confidential). Of our two scenes, it happened much more often on the more memory-intensive scene (that required using system memory in addition to 8GB GPU RAM). Our theory is it may be because we used multiple Unity cameras one-at-a-time, assigning them to the PBR Renderer camera field and then starting the render, but internally the render losing track of that camera before the rendering started. Because sometimes we would get the null exception, then re-drag the camera into the PBR Renderer camera field (on top of the old one), do the render again, and the render would work that time.

If the rendering actually started happening, the problem wouldn't happen at all.
Dreamwriter
 
Posts: 5
Joined: Wed Oct 31, 2018 5:41 pm

Re: Frequent null exceptions when trying to render with Recorder

Postby ChrisHekman » Wed Jan 09, 2019 10:25 am

ChrisHekman Wed Jan 09, 2019 10:25 am
Ill check if it can recreate the issue by reassigning cameras.
ChrisHekman
OctaneRender Team
OctaneRender Team
 
Posts: 218
Joined: Wed Jan 18, 2017 3:09 pm

Re: Frequent null exceptions when trying to render with Recorder

Postby ChrisHekman » Wed Jan 09, 2019 2:37 pm

ChrisHekman Wed Jan 09, 2019 2:37 pm
I have not been able to recreate this issue, even with larger scenes that use out of core.

Would it be possible for you to create an example scene that has the issue that isnt confidential?
ChrisHekman
OctaneRender Team
OctaneRender Team
 
Posts: 218
Joined: Wed Jan 18, 2017 3:09 pm

Re: Frequent null exceptions when trying to render with Recorder

Postby bwatanabe » Sun Mar 03, 2019 5:41 am

bwatanabe Sun Mar 03, 2019 5:41 am
I'm having this same problem.
What kind of file would be helpful to post? I'd be happy to.
bwatanabe
 
Posts: 5
Joined: Sun Mar 03, 2019 5:18 am

Re: Frequent null exceptions when trying to render with Recorder

Postby ChrisHekman » Mon Mar 04, 2019 2:48 pm

ChrisHekman Mon Mar 04, 2019 2:48 pm
bwatanabe wrote:I'm having this same problem.
What kind of file would be helpful to post? I'd be happy to.


The easiest is sharing the project with us. (You can pm it to me)
If that is not possible because of NDA/Sensitive material, a test case project that performs the the same error can help us solve the issue.
ChrisHekman
OctaneRender Team
OctaneRender Team
 
Posts: 218
Joined: Wed Jan 18, 2017 3:09 pm

Re: Frequent null exceptions when trying to render with Recorder

Postby bwatanabe » Thu Mar 21, 2019 2:44 am

bwatanabe Thu Mar 21, 2019 2:44 am
Just an update: I updated to the latest version of Unity and the problem was resolved. Have been running a newer version of Unity for at least a week with no issues.
bwatanabe
 
Posts: 5
Joined: Sun Mar 03, 2019 5:18 am

Return to Octane for Unity


Who is online

Users browsing this forum: Bing [Bot] and 1 guest

Sat Mar 23, 2019 9:04 pm [ UTC ]