Page 1 of 1

crash when loading octane in unity.

PostPosted: Wed Aug 29, 2018 12:25 pm
by adrenal36
Hello everyone, I cannot render a medium to large unity scene (only with standard non specular materials), and i keep getting an error every time I load octane :
Error loading node: Object reference not set to an instance of an object
OctaneUnity.Manager:LoadNode(Node, Byte[])
Octane.RenderTarget:OnUpdate(PBRRenderTargetComponent, RenderTarget)
OctaneUnity.ObjectLink`2:Update(HashSet`1, Boolean)

I read on the forum that it is driver related, i tried all combinations of unity (curently on 2017.4.10) and drivers (cuda 8, cuda 9, and nvidia official drivers, curently on cuda 8.0.2 drivers). I keep getting the same error and when i try to compile a scene with unity files ( with the same standard material on all objects, a seamless concrete texture ), as seen in the screenshot : ... nknown.png

The renderer works ok most of the time with the scenes provided by octane (courtyard, docking bay etc) but has errors on those also ( doesn`t finish rendering and sais it did, i have to restart unity and reload octane after rendering a scene to render another, etc.) I`m not shure if those are caused by the error i pasted or just bugs of the plugin.