OctaneRender™ for Blender 4.0 RC5 - 16.2.5 [OBSOLETE]

Forums: OctaneRender™ for Blender 4.0 RC5 - 16.2.5 [OBSOLETE]
Sub forum for plugin releases

OctaneRender™ for Blender 4.0 RC5 - 16.2.5 [OBSOLETE]

Postby azen » Wed Oct 10, 2018 1:46 am

azen Wed Oct 10, 2018 1:46 am
OctaneRender™ for Blender plugin. Windows, Linux and OSX versions. The download links provided are for Perpetual License Holders.

OctaneRender Studio subscribers can access their software from the "Downloads" section of their Customer Account Page.



This is a TEST version, so be prepared to have some issues. Do not use it for production.


NEW FEATURES SINCE LAST RELEASE

  • Upgrade to 4.0 RC5
  • Add "Light Linking invert" in AI light
  • Add option to support untonemapped image rendering with camera imager ("Render" - "Render" - "Prefer tonemap if applicable")
  • Add option ("User Preference" - "Add-ons" - "OctaneRender Engine" - "Generate Default UVs") to generate default UV Map when creating preset primitives
  • Optimize environment texture upload (do not upload unused textures)
  • Add option ("Data" - "Octane properties" - "Force load vertex normals") to fix issues in data transfer modifier
  • Adjust default and maximum values of parallel samples and max tile samples



FIXES SINCE LAST RELEASE

  • Fix particle texture setting missing
  • Fix random environment updates failures
  • Fix camera border mode render issue
  • Fix default power value from 0.9 to 1
  • Fix order of "Rotation" attribute in glossy material
  • Fix direction issue in toon light
  • Fix update failure when deleting toon lights
  • About the UV Maps issue, we have added an option to generate UV Maps automatically:
    • Add option ("User Preference" - "Add-ons" - "OctaneRender Engine" - "Generate Default UVs") to generate default UV Map when creating preset primitives.
    • If the users want to use startup file to test LiveDB materials, they need to modify the startup file (add a UV Map to the cube) then save it manually.



You can read about new features of OctaneRender™ 4.0 XB5 here:
viewtopic.php?f=33&t=68871

The installation consists from two parts:
1. OctaneRender™ Server
2. Blender - OctaneRender™ edition.

After starting OctaneServer it will take some time before the LiveDB tree and LiveDB material previews will be available from Blender - as OctaneServer caches the LiveDB data from remote server right after starting. But only the materials groups tree will be re-cached every time after server start, LiveDB material preview images will be cached only once - so only the very first OctaneServer start will need some more time before LiveDB tree will be available in Blender.
After the server is run - you can start rendering (or open a rendered view) from inside Blender.



Windows

DOWNLOAD (both distributives must be reinstalled, they depend on each other)

Blender Octane Edition - 16.2.5 (2.79)
Octane Server - 16.2.5


Linux

Installation:
- Just run the installer to see its command line keys.;)
- If you need to run OctaneServer - run it as daemon:
Code: Select all
$ OctaneServer &

DOWNLOAD

Blender Octane Edition - v16.2.5 Linux


OSX

Installation:
- Just run autoinstaller file.
- Or, if you know what you are doing, you can use the ZIP archive to copy .app files manually.

DOWNLOAD

Autoinstaller: Blender Octane Edition - v16.2.5 OSX Autoinstaller
ZIP archive: Blender Octane Edition - v16.2.5 OSX ZIP


Please note, in regards to Bug Reporting:

- Bug Reports in this section refer to plugin-specific bugs only. Bugs originating from the Octane Standalone should be reported to the Standalone Forum section instead

- For faster troubleshooting, please provide as much information as possible. Please include:
  • Your Hardware specifications (unless they are included in your signature)
  • A clear description of the issue you have found
  • Steps that you took to trigger this bug, so that we can reproduce it (ideally, please also provide screenshots. If possible, files for testing would also be appreciated).
  • Whenever possible, please confirm that this issue is only happening in the plugin, and not also in the Standalone Edition (if the bug occurs in both, it is likely that this issue should be reported in the OctaneRender Standalone section of the Forums).

- Please bear in mind - we are primarily an English-Language Forum. Please do not take offense if we request further clarification due to language differences.
azen
OctaneRender Team
OctaneRender Team
 
Posts: 638
Joined: Mon Jun 01, 2015 11:06 pm

Return to Releases


Who is online

Users browsing this forum: No registered users and 1 guest

Sun Aug 25, 2019 7:55 pm [ UTC ]