Strange Error Codes

Forums: Strange Error Codes
Sub forum for bug reports

Moderator: juanjgon

Forum rules
Before posting a bug report, please check the following:
1. That the issue has not already been disclosed
2. That the issue is specific to this plugin, and not Octane in general (Try reproducing it in Standalone)
Bugs related to the Octane Engine itself should be posted into the Standalone Support sub-forum.


All bug reports should include the information below, along with a detailed description of the issue and steps to reproduce it.
A. Operating System, including version (i.e. Win 7, OSX 10.11.2, Ubuntu 14.04, etc.)
B. Graphics Card(s) model (i.e. GTX 580 - 3GB, TITAN, etc.)
C. RAM Capacity (i.e. 6 GB)
D. Nvidia driver version (i.e. 7.50, 7.5.22)
E. OctaneRender Standalone version, if installed (i.e. 2.24.2, 2.23, etc.)
F. OctaneRender plugin version (i.e. v2.25 - 2.21)
G. Host application version, including build number if available (i.e. 3ds Max 2016 Build 18.0)

Strange Error Codes

Postby reelinspirations » Mon May 29, 2017 6:30 am

reelinspirations Mon May 29, 2017 6:30 am
Not sure what these mean, but they have the word Octane in them.
They pop up in the Houdini Dialog Window.

WARNING: OPUI_DialogPRM2: Symbol "open.val" value stepped on.

WARNING: OPUI_DialogPRM2: Symbol "open.val" value stepped on.

WARNING: OPUI_DialogPRM2: Symbol "open.val" value stepped on.

WARNING: OPUI_DialogPRM2: Symbol "open.val" value stepped on.

Qt Warn: External WM_DESTROY received for QWidgetWindow(0x205c294f760, name="RE_WindowWindow") , parent: QWindow(0x0) , transient parent: QWindow(0x0)
Qt Warn: External WM_DESTROY received for QWidgetWindow(0x205c294da80, name="RE_WindowWindow") , parent: QWindow(0x0) , transient parent: QWindow(0x0)
Qt Warn: External WM_DESTROY received for QWidgetWindow(0x205c294dfc0, name="RE_WindowWindow") , parent: QWindow(0x0) , transient parent: QWindow(0x0)
Qt Warn: External WM_DESTROY received for QWidgetWindow(0x205c294ece0, name="RE_WindowWindow") , parent: QWindow(0x0) , transient parent: QWindow(0x0)
Qt Warn: External WM_DESTROY received for QWidgetWindow(0x205c1bbca00, name="RE_WindowWindow") , parent: QWindow(0x0) , transient parent: QWindow(0x0)
Qt Warn: External WM_DESTROY received for QWidgetWindow(0x205918bd480, name="RE_WindowWindow") , parent: QWindow(0x0) , transient parent: QWindow(0x0)
Qt Warn: External WM_DESTROY received for QWidgetWindow(0x205c286ef20, name="RE_WindowWindow") , parent: QWindow(0x0) , transient parent: QWindow(0x0)
Qt Warn: External WM_DESTROY received for QWidgetWindow(0x205918bcd00, name="RE_WindowWindow") , parent: QWindow(0x0) , transient parent: QWindow(0x0)
Qt Warn: External WM_DESTROY received for QWidgetWindow(0x205c8912140, name="RE_WindowWindow") , parent: QWindow(0x0) , transient parent: QWindow(0x0)
Qt Warn: External WM_DESTROY received for QWidgetWindow(0x2058f6a3340, name="RE_WindowWindow") , parent: QWindow(0x0) , transient parent: QWindow(0x0)
Qt Warn: External WM_DESTROY received for QWidgetWindow(0x205c89120e0, name="RE_WindowWindow") , parent: QWindow(0x0) , transient parent: QWindow(0x0)
Qt Warn: External WM_DESTROY received for QWidgetWindow(0x2058f6a3880, name="RE_WindowWindow") , parent: QWindow(0x0) , transient parent: QWindow(0x0)
Qt Warn: External WM_DESTROY received for QWidgetWindow(0x205a183e080, name="RE_WindowWindow") , parent: QWindow(0x0) , transient parent: QWindow(0x0)
Qt Warn: External WM_DESTROY received for QWidgetWindow(0x205a183eb60, name="RE_WindowWindow") , parent: QWindow(0x0) , transient parent: QWindow(0x0)
Qt Warn: External WM_DESTROY received for QWidgetWindow(0x205a183dd80, name="RE_WindowWindow") , parent: QWindow(0x0) , transient parent: QWindow(0x0)
Qt Warn: External WM_DESTROY received for QWidgetWindow(0x20599bbb940, name="RE_WindowWindow") , parent: QWindow(0x0) , transient parent: QWindow(0x0)
Qt Warn: External WM_DESTROY received for QWidgetWindow(0x205a959f640, name="RE_WindowWindow") , parent: QWindow(0x0) , transient parent: QWindow(0x0)
Qt Warn: External WM_DESTROY received for QWidgetWindow(0x205a959d480, name="RE_WindowWindow") , parent: QWindow(0x0) , transient parent: QWindow(0x0)
Qt Warn: External WM_DESTROY received for QWidgetWindow(0x205a943ffa0, name="RE_WindowWindow") , parent: QWindow(0x0) , transient parent: QWindow(0x0)
Qt Warn: External WM_DESTROY received for QWidgetWindow(0x205a9771360, name="RE_WindowWindow") , parent: QWindow(0x0) , transient parent: QWindow(0x0)
WARNING: OPUI_DialogPRM2: Symbol "open.val" value stepped on.

WARNING: OPUI_DialogPRM2: Symbol "open.val" value stepped on.

*** OCTANE API MSG: Tried to access null node
*** OCTANE API MSG: Tried to access null node pin
*** OCTANE API MSG: Tried to access null node
*** OCTANE API MSG: Tried to access null node pin
*** OCTANE API MSG: Tried to access null node pin
*** OCTANE API MSG: Tried to access null node pin
*** OCTANE API MSG: Tried to access null node
*** OCTANE API MSG: Tried to access null node pin
*** OCTANE API MSG: Tried to access null node
*** OCTANE API MSG: Tried to access null node pin
*** OCTANE API MSG: Tried to access null node
*** OCTANE API MSG: Tried to access null node pin
*** OCTANE API MSG: Tried to access null node
*** OCTANE API MSG: Tried to access null node pin
*** OCTANE API MSG: Tried to access null node
*** OCTANE API MSG: Tried to access null node pin
*** OCTANE API MSG: Tried to access null node
*** OCTANE API MSG: Tried to access null node pin
*** OCTANE API MSG: Tried to access null node
*** OCTANE API MSG: Tried to access null node pin
*** OCTANE API MSG: Tried to access null node
*** OCTANE API MSG: Tried to access null node pin
*** OCTANE API MSG: Tried to access null node
*** OCTANE API MSG: Tried to access null node pin
*** OCTANE API MSG: Tried to access null node
*** OCTANE API MSG: Tried to access null node pin
*** OCTANE API MSG: Tried to access null node
*** OCTANE API MSG: Tried to access null node pin
*** OCTANE API MSG: Tried to access null node
*** OCTANE API MSG: Tried to access null node pin
reelinspirations
 
Posts: 33
Joined: Thu Jan 05, 2017 8:13 pm

Re: Strange Error Codes

Postby juanjgon » Mon May 29, 2017 8:39 am

juanjgon Mon May 29, 2017 8:39 am
I'm not sure about the origin of the PRM and Qt related messages, they seem something related to Houdini, but the *** OCTANE API MSG: Tried to access null node message usually means that in the scene there is an object that at the end didn't have any valid geometry (polygon for example) available for rendering.

Usually, the null node messages are not a problem for the rendering (in Houdini 16 they can be launch while working with bones, for example), but if you have a scene to reproduce these issues, send it to me to test it here.

Thanks,
-Juanjo
Computer Graphics Software Developer
Octane plugin development and support: LightWave and Houdini
User avatar
juanjgon
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 7302
Joined: Tue Jan 19, 2010 12:01 pm
Location: Spain

Re: Strange Error Codes

Postby snakeboxmedia » Sat Mar 23, 2019 11:27 pm

snakeboxmedia Sat Mar 23, 2019 11:27 pm
juanjgon wrote:I'm not sure about the origin of the PRM and Qt related messages, they seem something related to Houdini, but the *** OCTANE API MSG: Tried to access null node message usually means that in the scene there is an object that at the end didn't have any valid geometry (polygon for example) available for rendering.

Usually, the null node messages are not a problem for the rendering (in Houdini 16 they can be launch while working with bones, for example), but if you have a scene to reproduce these issues, send it to me to test it here.

Thanks,
-Juanjo


I just found this, I just got this error. rendered a sequence last night, no problems all good. shut down computer, started again today and now I can't open the file I get the long list of errors mentioned here, and houdini crashes at the end of it. Is my work just lost or was there a solution and work around to cover from this?

I am using the the latest octane 4 build for H17.5
snakeboxmedia
Licensed Customer
Licensed Customer
 
Posts: 67
Joined: Wed Jul 11, 2018 1:09 pm

Re: Strange Error Codes

Postby juanjgon » Sun Mar 24, 2019 8:22 pm

juanjgon Sun Mar 24, 2019 8:22 pm
Hi,

Sorry, for that. So do you say that the scene is corrupted? In this case, I'm not sure if recover it is going to be possible, I hope you have a backup of it. About the source of this problem, I'm not sure at all. A long time ago the plugin had a bug related to something like that (a problem that happened when the multi-thread scene extraction feature was enabled), but it had been fixed and I had never seen this problem until these days ... I wonder if the problem could be related to something broken in Houdini 17.5 or something like that.

Only one question. Are you using materials from LiveDB? What I've found is that some materials in this database have weird names with space characters and international strings that are not good for Houdini. Perhaps the problem could be related to these liveDB materials, but I'm not sure at all.

Of course, if you can reproduce this problem and you can send me the scene, It could help a lot to try to find the origin of the problem.

Thanks,
-Juanjo
Computer Graphics Software Developer
Octane plugin development and support: LightWave and Houdini
User avatar
juanjgon
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 7302
Joined: Tue Jan 19, 2010 12:01 pm
Location: Spain

Re: Strange Error Codes

Postby snakeboxmedia » Sun Mar 24, 2019 11:21 pm

snakeboxmedia Sun Mar 24, 2019 11:21 pm
Thank you for the reply!

No I am not using LiveDB, but the idea that something could have changed in H17.5 isn't impossible for sure. I obviously haven't seen this issue before either until now, so H17 never did this.

My scene was really simple, but I guess I will try to remember to keep auto save on (not sure why it's off by default in houdini), and see how things go. A little scary though.
snakeboxmedia
Licensed Customer
Licensed Customer
 
Posts: 67
Joined: Wed Jul 11, 2018 1:09 pm

Re: Strange Error Codes

Postby juanjgon » Mon Mar 25, 2019 10:40 am

juanjgon Mon Mar 25, 2019 10:40 am
Yes, this is something that we must investigate. Corrupting the scene file is something critical that must be fixed for sure, but I need to know how to reproduce the problem ... if you can reproduce it again and you can send the scene, this could help to try to reproduce the problem here, find how it is possible and fix the problem.

Thanks,
-Juanjo
Computer Graphics Software Developer
Octane plugin development and support: LightWave and Houdini
User avatar
juanjgon
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 7302
Joined: Tue Jan 19, 2010 12:01 pm
Location: Spain

Re: Strange Error Codes

Postby juanjgon » Mon May 06, 2019 8:34 pm

juanjgon Mon May 06, 2019 8:34 pm
Hi,

After a long time trying to reproduce and find the source of this issue, we've updated the 4.04.0.2 and 2018.1.2.1 plugin builds, adding new code to try to fix these rare problems related to the scene corruptions reported by some users.

Hope it helps to fix this weird issue,
-Juanjo
Computer Graphics Software Developer
Octane plugin development and support: LightWave and Houdini
User avatar
juanjgon
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 7302
Joined: Tue Jan 19, 2010 12:01 pm
Location: Spain

Return to Bug Reports


Who is online

Users browsing this forum: No registered users and 1 guest

Tue Feb 25, 2020 7:16 pm [ UTC ]