emission texture mapping

Forums: emission texture mapping
Sub forum for bug reports

Moderator: juanjgon

Forum rules
Before posting a bug report, please check the following:
1. That the issue has not already been disclosed
2. That the issue is specific to this plugin, and not Octane in general (Try reproducing it in Standalone)
Bugs related to the Octane Engine itself should be posted into the Standalone Support sub-forum.


All bug reports should include the information below, along with a detailed description of the issue and steps to reproduce it.
A. Operating System, including version (i.e. Win 7, OSX 10.11.2, Ubuntu 14.04, etc.)
B. Graphics Card(s) model (i.e. GTX 580 - 3GB, TITAN, etc.)
C. RAM Capacity (i.e. 6 GB)
D. Nvidia driver version (i.e. 7.50, 7.5.22)
E. OctaneRender Standalone version, if installed (i.e. 2.24.2, 2.23, etc.)
F. OctaneRender plugin version (i.e. v2.25 - 2.21)
G. Host application version, including build number if available (i.e. 3ds Max 2016 Build 18.0)

emission texture mapping

Postby WhyGee » Thu Feb 11, 2016 10:16 am

WhyGee Thu Feb 11, 2016 10:16 am
Hi,
I'm trying to map textures to grids with uv mapping as light sources and it would seem that if I use the Object Properties to set emission, then the texture mapping looks incorrect sort of like a pinched polar cap. If I use an emission material where the texture is connected into the distribution port, it ignores uvs and looks like it's sampling as an environment sphere. Only when connecting the texture to the efficiency port does the mapping look correct. Is that how it's supposed to be? does the distribution not use the texture as an optimization for sampling the light source?
Would appreciate your input on this.
Attached are 2 screenshots, one with default emission material asset, and the other is with modified texture connected to efficiency.

Thanks
Yaniv
Attachments
emission_modified_asset_texture_mapping1.JPG
emission_default_asset_texture_mapping1.JPG
default material emission
WhyGee
Licensed Customer
Licensed Customer
 
Posts: 169
Joined: Sun Jun 22, 2014 9:10 am

Re: emission texture mapping

Postby juanjgon » Thu Feb 11, 2016 10:32 am

juanjgon Thu Feb 11, 2016 10:32 am
You are right, this is an old issue that I must fix. The texture mapping in the Object Properties is designed to support only IES files. I has a projection node to map the IES in the geometry, so as you can see the UV map projection from the object doesn't work. I need to add an option to select if you are using an IES light or a UV texture map.

Currently you must use the emission material, linking the texture to the efficiency port. This is the how it's supposed to be. The default emission asset is wrong, I will fix it for the next build.

Thanks for reporting!

-Juanjo
Computer Graphics Software Developer
Octane plugin development and support: LightWave and Houdini
User avatar
juanjgon
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 7558
Joined: Tue Jan 19, 2010 12:01 pm
Location: Spain

Re: emission texture mapping

Postby WhyGee » Thu Feb 11, 2016 11:31 am

WhyGee Thu Feb 11, 2016 11:31 am
Thanks alot!
WhyGee
Licensed Customer
Licensed Customer
 
Posts: 169
Joined: Sun Jun 22, 2014 9:10 am

Return to Bug Reports


Who is online

Users browsing this forum: No registered users and 1 guest

Wed May 27, 2020 2:15 am [ UTC ]