Motion Vector Off when Enable Motion Blur OFF

Forums: Motion Vector Off when Enable Motion Blur OFF
Sub forum for bug reports

Moderator: juanjgon

Forum rules
Before posting a bug report, please check the following:
1. That the issue has not already been disclosed
2. That the issue is specific to this plugin, and not Octane in general (Try reproducing it in Standalone)
Bugs related to the Octane Engine itself should be posted into the Standalone Support sub-forum.


All bug reports should include the information below, along with a detailed description of the issue and steps to reproduce it.
A. Operating System, including version (i.e. Win 7, OSX 10.11.2, Ubuntu 14.04, etc.)
B. Graphics Card(s) model (i.e. GTX 580 - 3GB, TITAN, etc.)
C. RAM Capacity (i.e. 6 GB)
D. Nvidia driver version (i.e. 7.50, 7.5.22)
E. OctaneRender Standalone version, if installed (i.e. 2.24.2, 2.23, etc.)
F. OctaneRender plugin version (i.e. v2.25 - 2.21)
G. Host application version, including build number if available (i.e. 3ds Max 2016 Build 18.0)

Motion Vector Off when Enable Motion Blur OFF

Postby blobbybarack » Mon Jul 01, 2019 9:57 am

blobbybarack Mon Jul 01, 2019 9:57 am
Everything in the tile.
When MB off at the Rop Level you can't render MotionVector (All Grey).
Don't make any sence as you use Motion Vector to generate MotionBlur at Comp.

I
blobbybarack
Licensed Customer
Licensed Customer
 
Posts: 195
Joined: Sun Feb 03, 2013 9:11 pm
Location: Paris

Re: Motion Vector Off when Enable Motion Blur OFF

Postby juanjgon » Mon Jul 01, 2019 10:03 am

juanjgon Mon Jul 01, 2019 10:03 am
Hi,

Yes, sorry, it makes full sense, because to know what information must be exported to the motion vectors pass, the plugin must extract and process all the motion blur information from the scene.

When you enable the motion vectors pass, the beauty rendering is done without MB to allow you to apply the MB in post, but the motion blur options must be enabled to let Octane extract and process all the motion data and build this motion vectors pass.

Hope it helps,
-Juanjo
Computer Graphics Software Developer
Octane plugin development and support: LightWave and Houdini
User avatar
juanjgon
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 6951
Joined: Tue Jan 19, 2010 12:01 pm
Location: Spain

Re: Motion Vector Off when Enable Motion Blur OFF

Postby blobbybarack » Mon Jul 01, 2019 11:31 am

blobbybarack Mon Jul 01, 2019 11:31 am
oK sorry my bad.
I was tricked by some message return by the console in the information mode about calculated the matrix for MB with MB off.
One more general question please.
Does MB step parameters have an impact on the vector pass image ?
Anyway, thanks you for the fast feedback.
blobbybarack
Licensed Customer
Licensed Customer
 
Posts: 195
Joined: Sun Feb 03, 2013 9:11 pm
Location: Paris

Re: Motion Vector Off when Enable Motion Blur OFF

Postby juanjgon » Mon Jul 01, 2019 12:03 pm

juanjgon Mon Jul 01, 2019 12:03 pm
Hmm, this is a good question. A motion vector pass can't store curved trails data, so I suppose that the MB steps parameters have no effect in this pass and it is safe to leave them with the default values.

Thanks,
-Juanjo
Computer Graphics Software Developer
Octane plugin development and support: LightWave and Houdini
User avatar
juanjgon
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 6951
Joined: Tue Jan 19, 2010 12:01 pm
Location: Spain

Return to Bug Reports


Who is online

Users browsing this forum: No registered users and 1 guest

Thu Oct 17, 2019 2:55 am [ UTC ]