RTX not working in Houdini

Forums: RTX not working in Houdini
Houdini Integrated Plugin

Moderator: juanjgon

RTX not working in Houdini

Postby rohandalvi » Wed Dec 18, 2019 12:26 pm

rohandalvi Wed Dec 18, 2019 12:26 pm
Hi,

Just tested similar scenes in Octane standalone and Houdini with Octane 2020. RTX works just fine in standalone but it has no effect on the scene in Houdini.

I'm sending a dropbox link to the models and the octane standalone scene and houdini scene so you can test it. You'll need to reload the models.

I am on the latest nvidia drivers. Testing with a single 2080ti

https://www.dropbox.com/sh/xc4zrojf1x92ar8/AACxLJNDvoWUac0bxONGOh2Ta?dl=0

regards
Rohan
Attachments
houdini rtx.JPG
houdini no RTX1.JPG
standlone rtx.JPG
standlaone nortx.JPG
rohandalvi
Licensed Customer
Licensed Customer
 
Posts: 132
Joined: Tue Apr 20, 2010 7:39 am

Re: RTX not working in Houdini

Postby juanjgon » Wed Dec 18, 2019 7:03 pm

juanjgon Wed Dec 18, 2019 7:03 pm
Thanks for the scene. Let me check what's going on ... I also think that something related to the RTX feature can be broken on the plugin side. I hope to know more soon ...

Thanks,
-Juanjo
Computer Graphics Software Developer
Octane plugin development and support: LightWave and Houdini
User avatar
juanjgon
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 7662
Joined: Tue Jan 19, 2010 12:01 pm
Location: Spain

Re: RTX not working in Houdini

Postby snakeboxmedia » Fri Dec 20, 2019 3:30 am

snakeboxmedia Fri Dec 20, 2019 3:30 am
juanjgon wrote:Thanks for the scene. Let me check what's going on ... I also think that something related to the RTX feature can be broken on the plugin side. I hope to know more soon ...

Thanks,
-Juanjo


Would love an update on this, as I am getting FOMO from seeing everyone else playing with the RTX render times, and since I only have the houdini plugin, I'm feeling left out ;)
snakeboxmedia
Licensed Customer
Licensed Customer
 
Posts: 78
Joined: Wed Jul 11, 2018 1:09 pm

Re: RTX not working in Houdini

Postby juanjgon » Thu Dec 26, 2019 5:04 pm

juanjgon Thu Dec 26, 2019 5:04 pm
Sorry, I'm still investigating this issue. It seems somehow related to the motion blur. If you disable the MB in the ROP node the RTX feature seems to work fine ... I'm trying to figure out if this is some kind of Octane limitation or a bug.

Thanks,
-Juanjo
Computer Graphics Software Developer
Octane plugin development and support: LightWave and Houdini
User avatar
juanjgon
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 7662
Joined: Tue Jan 19, 2010 12:01 pm
Location: Spain

Re: RTX not working in Houdini

Postby snakeboxmedia » Sun Dec 29, 2019 9:59 am

snakeboxmedia Sun Dec 29, 2019 9:59 am
juanjgon wrote:Sorry, I'm still investigating this issue. It seems somehow related to the motion blur. If you disable the MB in the ROP node the RTX feature seems to work fine ... I'm trying to figure out if this is some kind of Octane limitation or a bug.

Thanks,
-Juanjo


I ran a test with motion blur off (quite an unfortunate feature to be broken), and yes indeed it works. Still some features missing but I do believe these were fixed in the new XB2 stand alone build? so I can only guess we will see them in the next houdini build too.

I am getting a 2.33x speed increase with RTX ON.

Added auto bump map support for RTX primitives.

Added support for UV sets 2 and 3 for RTX primitives.

Added support for vertex attributes for RTX primitives.

Particularly the vertex attribute is apparent in my test images as you can see on the trees in the RTX on version, the colour variation driven by attrib isn't working.
Attachments
rtx_on.jpg
RTX ON
rtx_off.jpg
RTX OFF
snakeboxmedia
Licensed Customer
Licensed Customer
 
Posts: 78
Joined: Wed Jul 11, 2018 1:09 pm

Re: RTX not working in Houdini

Postby juanjgon » Mon Dec 30, 2019 6:45 pm

juanjgon Mon Dec 30, 2019 6:45 pm
Finally, the problem with the RTX feature is indeed related to the motion blur. Currently, the MB is not supported by RTX, so Octane falls back to the CUDA rendering if the motion blur is enabled. It seems that OptiX ray trancing is really slow while rendering with motion blur, and the deformations motion blur is not even supported at all, so the native Octane CUDA code is better in this case.

If you want to improve your render times using the RTX feature, you need to disable all the motion blur options in the Octane ROP node.

Thanks,
-Juanjo
Computer Graphics Software Developer
Octane plugin development and support: LightWave and Houdini
User avatar
juanjgon
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 7662
Joined: Tue Jan 19, 2010 12:01 pm
Location: Spain

Return to Houdini


Who is online

Users browsing this forum: No registered users and 5 guests

Thu Jul 02, 2020 10:20 am [ UTC ]